1. まとめトップ

rails new XXXでSSLエラーがでるので調査中→解消
rails s でsqlite3でsqlite3_nativeがないとエラーが出るため調査中
→解決されている方のブログ通り実行したところ解消
  http://d.hatena.ne.jp/yuum3/comment?date=20130227§ion=1361931149

Windows7 64bit版にインストールした結果です

64bit Windowsでも64bit版を入れようとするとエラーが出るため32bit版をインストールします

RailsInstallerはまだリリースされていません(2/27時点)

BitNami RubyStackはLinux、MaxOS版、Windows版はdev版が出ています

Ruby2.0の入手

Ruby2.0のインストール

1)rubyinstaller-2.0.0-p0.exeを実行します
途中の関連づけのチェックボックスは3つともチェックしました

2) DevKitをC:\Ruby200\devkitへ展開します

3) スタートメニューから「Ruby コマンドプロンプトを開く」を実行しコマンドプロンプトを起動します

4) devkitのディレクトリへ移動しdevkitをインストールします
 C:\Ruby200\devkit> ruby dk.rb init
 C:\Ruby200\devkit> ruby dk.rb install

cacert.pem をインストール

プロキシ管理下の場合

Rails4 beta1のインストール

念のためコンソールを開き直しました

Sqlite3をビルドする

2) ダミーのプロジェクトを作成し関連するgemをインストールします
c:\Ruby200\work>rails new hello

3)sqlite3のgemをアンインストール
c:\Ruby200\work>gem uninstall sqlite3

4)C:\Ruby200\sqlite3\にダウンロードしたtar.gzファイルを解凍

1 2