1. まとめトップ

【解決策】WindowsでGoogle/YouTube以外にアクセスできなくなった

最近、GoogleやYouTubeはアクセスできるのに、YahooやTwitterはアクセスできないという謎の現象に2回遭遇しました。しかも、2回とも別の原因で、解決策も異なったのでかなり困りました。そのため、自分の備忘も兼ねて2種類の原因と解決策をまとめます。

更新日: 2017年09月20日

0 お気に入り 17869 view
お気に入り追加

この記事は私がまとめました

lowplさん

一部のWebサイトにはアクセスできるのに他のサイトへはアクセス不能

最近、GoogleやYouTubeはアクセスできるのに、YahooやTwitterはアクセスできないという謎の現象に2回遭遇しました。

ちなみに、以下のような場合は他の原因が考えられますので、このまとめは役に立たないと思いますので、別の解決策を探してください。

・GoogleやYouTubeも含め全てのWebサイトにアクセスできない場合
・ほとんどのWebサイトにアクセスできて特定のサイトだけアクセスできない場合

GoogleやYoutubeにだけアクセスできる理由

今回遭遇した2つの事象で、GoogleやYouTubeにだけアクセスできる理由はどちらも同じで、『IPv6アドレスでの通信は正常にできるが、IPv4アドレスでの通信ができなくなっているため』でした。
GoogleやYouTubeのサイトはIPv6に対応していますが、YahooやTwitterのサイトはIPv6には対応していないのでこのような不思議な事象が発生します。(2017年9月現在)
そのため、GoogleやYouTube以外でもIPv6対応しているサイトにはアクセスできました。

コマンドプロンプトからnslookupコマンドで「www.google.co.jp」を調べると、IPv6アドレスが設定されていることが分かります。

Googleは、アドレス数が多い次世代インターネットプロトコル(IP)の利用を推進する取り組みの一環として、IPv6経由で「YouTube」を利用可能にした。

YouTubeもIPv6に対応しています。

インターネット上の各々のサービスサイト(ウェブサイトなど)でも、Googleなど大手中心にIPv6対応が進みつつある

今後、世の中のWebサイトのほとんどがIPv6に対応するようになったら、今回のような事象には遭遇することがなくなるのかもしれません。

では、今回遭遇した事象における原因と解決策をそれぞれ紹介します。

●原因・解決策1:IPv4アドレスが正常に取得できていない

コマンドプロンプトでipconfigコマンドを実行してみましょう。
IPv4アドレスが「169.254.XXX.XXX」(XXXは0.0~255.255の間の数値)になっている場合、IPv4アドレスが正常に取得できない状態です。

正常に取得できていない場合、IPv4アドレスを調べると「169.254.XXX.XXX」になっています。(画像は正常に取得できている際のものです)

このようになってしまう原因は様々です。
たとえば以下のような原因があります。

DHCPサーバー(無線LANルーター)の故障

動的IPアドレス割り当てを実施しているルーターが故障している可能性が考えられます。

ソフトウェアによる問題

ウイルス対策ソフトなどのセキュリティソフトがDHCPの通信の邪魔をしている場合があるようです。

アドレスプールの不足

DHCPによる動的割り当てのために用意したアドレスプールを超える数のクライアントが同時にネットワークに接続された場合などに起きます。
会社等でDHCPを使っている場合は起こり得ますが、家庭のようにネットワークにつなぐ機器が少ない場合は起きる可能性は低いでしょう。

今回一番近かったのは「DHCPサーバー(無線LANルーター)の故障」で、DHCPサーバではないのですが、家に幾つかあるルータのうちの一つがおかしくなっていたようです。
そのルータの電源を切り(コンセントを抜き)、再起動したら直りました。

●原因・解決策2:デバイスドライバの故障

こちらは原因の特定と解決に時間がかかりました。
コマンドプロンプトで調べてもIPv4アドレスは「169.254.XXX.XXX」ではなく、「192.168.XXX.XXX」になっており、正常に取得できてるように見えたためです。

原因調査で以下のようなことを実施しましたが、原因特定や解決には至りませんでした。

・IPv4アドレスの取得状況調査⇒「192.168.XXX.XXX」で問題なし
・YahooのIPアドレス(IPv4)へのping⇒正常に応答あり
・ウイルス対策ソフトを一時的に停止⇒状況変化なし
・IPv4アドレスを固定IPアドレス(手動設定)に変更⇒状況変化なし
・Windowsの再起動⇒状況変化なし
・ルータやONU(光回線終端装置)の再起動⇒状況変化なし

今回は実施しませんでしたが、以下のような調査もやると良いと(後で)思いました。

•ルータのランプ状態は正常か
•LANケーブルを交換して同じ症状になるのか
•PCのファイアーウォール機能を無効にしても同じ症状になるのか

原因が全く分からず、色々ググっていたところ、以下の情報を見つけました。

インターネットやLANなどに接続ができなくなってしまった場合、ネットワークアダプターのドライバーを削除および再インストールすることで、問題が改善される可能性があります。

そのため、ドライバーの削除と再インストールを実施してみたところ、IPv4にしか対応していないWebサイトにもアクセスできるようになりました。
原因はネットワークアダプターのドライバーの不具合だったようです。

1 2